Inicio | Artículos | Biografías | Cursos | Entrevistas | Frases | Libros | Diccionario | Presentaciones | Servicios | Videos | Mapa Web | Enlazar | Contactar | Acerca de


CURSO/TUTORIAL DE ALGORITMOS
Introducción
¿Qué es un Algoritmo?
¿Qué es un Ordinograma?
Elementos Básicos
Tipos de Datos
Identificadores
Variables
Constantes
Operadores y Expresiones
Tipos de Datos Definidos por el Programador
Datos de Tipos Enumerados
Datos de Tipos Subrangos
Instrucciones Primitivas
Instrucción de Asignación
Instrucción de Salida
Instrucción de Entrada
Estructura de un Algoritmo
Partes de un Algoritmo
Cabecera
Declaraciones
Cuerpo
Sintaxis de un Algoritmo
Comentarios
Introducción a los Diagramas de Flujo
Asignación
Entrada y Salida
Inicio y Fin
Decisiones
Instrucciones de Control
Instrucciones Alternativas
Instrucciones Repetitivas
Instrucciones De Salto
Llamadas a Subalgoritmos
¿Qué es un Subalgoritmo?
Subprogramas
Procedimientos
Declaraciones Locales y Globales
Parámetros
Funciones
Representación mediante Diagramas de Flujo
CarlosPes.comCurso de Diseño de Algoritmos > Anidamiento Alternativa Doble en Doble

Anidamiento de una Instrucción Alternativa Doble en otra también Doble

¿Cómo se anida una instrucción alternativa doble en otra también doble?

En pseudocódigo, para anidar una alternativa doble en otra, se utiliza la sintaxis:
si ( <expresión_lógica_1> )

   /* Inicio del anidamiento */
   si ( <expresión_lógica_2> )
      <bloque_de_instrucciones_1>
   sino
      <bloque_de_instrucciones_2>
   fin_si
   /* Fin del anidamiento */

sino
   <bloque_de_instrucciones_3>
fin_si
O también:
si ( <expresión_lógica_1> )
   <bloque_de_instrucciones_1>
sino

   /* Inicio del anidamiento */
   si ( <expresión_lógica_2> )
      <bloque_de_instrucciones_2>
   sino
      <bloque_de_instrucciones_3>
   fin_si
   /* Fin del anidamiento */

fin_si
Ejemplo: Se quiere diseñar el algoritmo de un programa que:

1º) Pida por teclado la nota (real) de una asignatura.
2º) Muestre por pantalla:

"APTO", en el caso de que la nota sea mayor o igual que 5 y menor o igual que 10.
"NO APTO", en el caso de que la nota sea mayor o igual que 0 y menor que 5.
"ERROR: Nota incorrecta.", en el caso de que la nota sea menor que 0 o mayor que 10.

En pantalla:
Salida por pantalla del programa introduzca nota
Una solución al problema es:
algoritmo Calificacion_segun_nota

variables
   real nota

inicio
   escribir( "Introduzca nota (real): " )
   leer( nota )

   si ( nota >= 5 y nota <= 10 )
      escribir( "APTO" )
   sino

      /* Inicio del anidamiento */
      si ( nota >= 0 y nota < 5 )
         escribir( "NO APTO" )
      sino
         escribir( "ERROR: Nota incorrecta." )
      fin_si
      /* Fin del anidamiento */

   fin_si
fin
En ordinograma:
Algoritmo en Ordinograma con Anidamiento de Alternativa Doble en Doble
Como se puede observar, el anidamiento de instrucciones alternativas permite ir descartando valores hasta llegar al bloque de instrucciones que se debe ejecutar.
Artículos Interesantes
Artículos de Desarrollo Web
Artículos de Informática
Artículos de Programación
Artículos de SEO
Cursos/Tutoriales de Informática
Curso/Tutorial de Algoritmos
Curso/Tutorial de Informática Básica
Curso/Tutorial de Ingeniería del Software
Curso/Tutorial de Lenguaje C
Curso/Tutorial de Marketing en Internet
Curso/Tutorial de Turbo Pascal
Curso/Tutorial de Representación de los Datos
Curso/Tutorial para Webmasters
Curso/Tutorial Web 2.0
Curso de SEO
Libros de Carlos Pes
36 Pasos Básicos para Desarrollar un Sitio Web
Empezar de Cero a Programar en Lenguaje C
Fundamentos del SEO
Libros Recomendados
Libros de Analítica Web
Libros de Desarrollo Web
Libros de Java
Libros de Lenguaje C
Libros de Marketing Online
Libros de Pascal (Turbo Pascal)
Libros de SEO
Libros de Visual Basic
Recursos de Informática
Diccionario de Informática
Ejercicios de Programación
Guías de uso de Software
Sintaxis de Lenguajes de Programación
Biografías
Entrevistas
Frases y Citas
Recursos Educativos
Presentaciones Educativas
Videos Educativos
Enlaces Web
Servicios
Desarrollo de Sitios Web
Diseño Web
Aplicaciones Web
Marketing Online
Formación y Conferencias
Consultoría
Acerca de Carlos Pes
Bibliotecas
Colaboradores
Contactar
Enlazar
Librerías
Perfiles en Internet
Mapa Web
Blog de Carlos Pes Blog de Carlos Pes
Google+ CarlosPes.Com en Google+
© 2006-2017 CarlosPes.com