Blog en Blogger Perfil en Slideshare Bookmarks en Delicious Perfil el Facebook Perfil en Twitter Fotos en Flickr Página en MySpace Canal en YouTube Perfil en Google Perfil en Google
Búsqueda personalizada
EMPEZAR DE CERO A PROGRAMAR EN LENGUAJE C
 RecursosExplicación de las soluciones a los Test de Autoevaluación > Pregunta 12.6
Solución:

Véase en la página 342 del libro:



De modo que, por un lado, numero debería ser de tipo entero en vez de real para poder usarse como expresión en una alternativa múltiple y, además, no es correcto escribir:

 < 0

ni

 > 0

en donde deberían aparecer uno o más valores.


→ D es VERDADERA

El algoritmo podría escribirse correctamente con dos alternativas dobles, anidando una dentro de otra:

algoritmo Test_11_4

variables
   real numero = -40.7

inicio
   si ( numero = 0 )
      escribir( "CERO" )
   sino
      si ( numero > 0 )
         
escribir( "POSITIVO" )
      sino
         
escribir( "NEGATIVO" )
      fin_si
   fin_si
fin
 
 Recursos Explicación de las soluciones a los Test de Autoevaluación > Pregunta siguiente